Event Alerts

Please enable the javascript to submit this form

Eheim Parts Problem

8 years 1 month ago #31645 by Jack
Replied by Jack on topic Eheim Parts Problem
Never been a fan of the canisters. Why not scrap it and pick up an AC110. Great filter, no issues.

Got Dempseys??? Check out:
www.allthingsdempsey.com

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #31643 by Kegger22
Replied by Kegger22 on topic Eheim Parts Problem
Trilby's?

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #31642 by mikeg2929
Replied by mikeg2929 on topic Eheim Parts Problem
No good suggestions for you. A leaky canister is a disaster waiting to happen. Good luck.

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #31640 by Neo1
Eheim Parts Problem was created by Neo1
I have two problems with two different Eheim Canisters. I am hoping someone may be able to point me in the direction to get these resolved.

First Problem:

I have a model 2229 Wet/Dry canister, which appears to have a leaking pump. Not the O-Ring! The pump leaks on one corner only, possibly a stress crack. I just took the thing offline because I figured I really did not need it as my load had reduced significantly.

However, recently I decided to repopulate the tank, so I went to a LFS and he recommended the Eheim Part store. They want $280 for the pump head. When I googled the part number I found one supplier (Marinedepot.com) that advertised it for $155. Does anyone know if that seems like a good price? Like I said, I only found one supplier, so I do not know if there are others out there that are reasonable.

Second Problem:

I have a model 2128 Pro II Thermofilter. This is a wonderful filter that apparently doubles as a Bouillabaisse maker if the thermostat fails. I checked with Eheim and they do not sell a $10 Thermostat for the unit; they only sell a Thermocontrol Module, which retails for $220. Are you kidding me??? I can get a 300 Watt Eheim Heater for 30 bucks with a thermocontrol module that does not slow-cook my tank.

When I googled this part number, I got zero results. I doubt this can be resolved because even if I could get the part at half price, I am not going to pay $110 for a part that I can effectively replace for $30. However, venting aside, if anyone knows a fix for this problem, I would appreciate it.

Please Log in or Create an account to join the conversation.

More
Time to create page: 0.102 seconds